97 caravan electrical problem

Would like a schematic of electrical . I don't have a horn, cruise control, and cig lighter either. also when I start van and turn on heater, fan blows good but when i shift in
reverse blower stops, or when i push in rear defogger the blower shuts off. Have checked relays and fuses.
Any ideas ?
thanks larry
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
also see something on web about clockspring. What and where is it?

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
On Fri, 9 Nov 2007 01:18:00 -0500, "Larry Dale"

The"clockspring" is the flexible contact in the back of the steering wheel that feeds the horn connection and anything else in the steering wheel down to the column. It WON'T be the problem.
--
Posted via a free Usenet account from http://www.teranews.com


Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
On Fri, 9 Nov 2007 00:58:15 -0500, "Larry Dale"

Bad ground somewhere by the sound of things.
--
Posted via a free Usenet account from http://www.teranews.com


Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
rechecked fuses after i found out i had no backup lights and it was blown. Strangely it fixed my blower problem(no longer cuts off when i push defroster ). But airbag light is on and still have no horn or cruise. I also checked connections going into clockspring ass. I can ground horn wire at connector and it blows. I guess that only leaves clockspring mechanism. Called advance they said the clockspring ass. is dealer only part. Rats!! Guess i'll make a trip to the junkyard. thanks larry "clare at snyder.on.ca" wrote in message wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
wrote:

shift
Why don't you take the car to the dealer and have them replace the clockspring as per Recall#B24 before you start poking around and setting off the air bags with your test lite
Glenn Beasley Chrysler Tech
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
This vehicle has 193397 miles on it. Would they still replace it?
wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
wrote:

shuts
One more time, Take it to the dealer and have then Perform the B24 "Lifetime warranty recall
Glenn
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Thanks I'll take it to dealer tomorrow. Did'nt know it was lifetime recall.
Larry
wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
took it to the dealear and they looked up vin number on it and it was replaced in about an hour. Now I have everthing working.
But i have a new problem .My brake light stays on indicator lamp stays on. I have good brakes and the pads are all fine. I checked the switch for the emergency brakes and it checks ok. Fluid is also ok. When i engage the emergency brake it still rolls. Maybe someone disconnected them. Would that make the indicator lamp stay on?
wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Related Threads

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.