'98 Dodge Caravan speed sensor problem

My van has been displaying the classic symptoms of a speed sensor problem - service engine light, funny shifting, speedometer dead. My mechanic has, with some difficulty, found the input and output speed
sensors and replaced them and still no go. He showed me a different part, which he recieved as a speed sensor, and he has no idea where it goes. Is this the ABS speed sensor, and could it cause the same problem? He's going to crack open behind the dash next week to take a look at the instrument cluster, but will a fault there cause the same problem (the tranny not recieving the speed information?) Could the speed sensors he replaced be mixed up (the output in the input and vice versa?)
-JD
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
As an addendum:
He showed me the old input and output sensors, which looked just like this: http://www.1aauto.com/1A/SpeedSensor/Dodge/Caravan/1ATRS00007/413318&ovchn=OTHER&ovcpn=NexTag&ovcrn=&ovtac=CMP
but I *believe* the other 'sensor', the one he had no idea about, was this:
http://www.1aauto.com/1A/SpeedSensor/Dodge/Caravan/1ATRS00029/414431&ovchn=OTHER&ovcpn=NexTag&ovcrn=&ovtac=CMP
Could the second part be the problem, and where is it located?
-JD
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.