'99 Durango - No fire

My '99 Durango 4WD 5.2 is getting no fire. With the key in the on position, there is no voltage at the coil input terminal. Swapped out the ASD relay
with a known good one and checked the fuse. New pickup coil and new crank sensor. I can hear the fuel pump run for a moment when turning to the on position, and can smell fuel after a start attempt or two. No codes. Ignition switch maybe? Any ideas?
Thanks
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

maybe ECU, or some broken wire/ground. if you want you can manually bypass ASD relay, or any other relay in that sense.
I think you need to take a look at the wiring for thi sproblem first.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
wrote:

maybe ECU, or some broken wire/ground. if you want you can manually bypass ASD relay, or any other relay in that sense.
I think you need to take a look at the wiring for thi sproblem first.
Thanks, I was hoping to avoid messing with the ignition switch if possible. I'll keep checking wires in the meantime.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

ignition switch is kinda simple. you turn the key and check if you get potential on the output wires. that's it. get a pin, and voltmeter. turn the key on, check if you get power on the necessary cables. that's much simpler then tracing soem random problems down the road.
regards,
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.