Dodge 600 A413 transmission problem, please help!!

Hi , I'm from Hungary, and I have a 1986 dodge 600 SE 2.5l non-turbo Automatic transmission, its shifts great without any noises, fluid is Dexron III, and always checked, and in the right level.

The car has only 90k mile and in a very good shape, about 2 mounths ago
the transmission started to leak, I went to my repair shop, he said its
torque converter oil seal has to be replaced, I wasn't convinced, and later I saw that the leak is comming from the differential cover, I changed the gasket, then leak was stopped, 1 month later, it started to
leak from the same place, again he said its is the torque converter oil
seal.
they got the tranny down, they reilized that the leak came from the half shaft oil seal and NOT the torque converter seal, so they put it on again and here the problem started:
when shift into R, N, D it drives forward!!!, but when shift to 1,2 then it seems like its in "N"
then, BACK from 2 or 1 to D,N,R NOTHING happens!!, then in P it drives forward, but get locked at once by "somthing I don't know but its what usually locks the trans in P"
the mechanic said "I don't have ANY IDEA what can be this, I got 10s of trannys down and never happned like this before!!!!!!!"
unfortunatly, US cars are extremly rare here in Hungary, so I write to you.
I have the 3 1986 chrysler factory manuals.
please help me in this problem, I'm totally in panic!!
Riyad
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
try to adjust you shift linkage or cable.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.