fan belt comming off

I had the factory fan belt replaced with a NAPA replacement. The origional had no problems. The new one comes off 3 times a month. The mechanic puts
it back on for free. BUT !!!! what a pain. Bought a new one & it does the same thing. Help.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Since we have no idea what kind of vehicle it is I wouldn't expect to many replies on this.
Glenn Beasley Chrysler Tech
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

My Tarrot Reader left town, so I will ask you these questions... What Year, Vehicle, Engine size, A/C? Was there a specific reason for having the original belt replaced? Fan V-belt or serpetine belt? FWD vehicles do not have a FAN belt, the fans are electric.
Ever had the Tensioner replaced?-J
--
Message posted via http://www.carkb.com

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
On Sun, 27 Nov 2005 16:21:46 -0500, mtmike wrote:

Best guess? The tensioner or one of the pulleys is out of whack.
--
I've spent a great deal of money on Whiskey, Women and Fast Cars

The rest I've squandered.
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.