help needed -- Dodge Dynasty won't keep running

Hi -- hoping someone might be able to help me solve a problem.
My 1991 Dodge Dynasty (6-cylinder, 3 liter) was running more or less OK, and then I went out one day and started it, only to have it stall after
the engine had run for about two seconds. It does this repeatedly -- starts, runs for about two seconds, and then stalls.
I can kind of keep it running, I found, if I repeatedly press and release the gas pedal very quickly (as quickly as I can) once it's started, but it runs incredibly rough while I do that. Then, when I stop doing it, it stalls, even if it's warmed up a bit by then.
Any opinions as to what's wrong appreciated. Nothing else has changed with the car lately. I did have a look at the air filter, but that looks OK.
Jacques
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Does this vehicle have a security system? has the battery gone dead or been replaced? If so take the key and lock and unlock the drivers and passenger door and then retry to start the engine
Glenn Beasley Chrysler Tech
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
vacuum leak. map sensor (next to the alternator, attached to the intake. ). squeral damage.
Jacques Clouseau wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.