Help with Infinity System on my LHS

I have a 2000 Chrsler LHS with the Infinity sound system and I changed out the head unit to an HD radio. The system never sounded good before (little bass, I run out of power to the speakers). Any way to
diagnose to see if I have a bad amplifier (it gets warm while in use). I am almost ready to just totally bypass and rewire the car but that is a royal pain.
Any suggestions and yes the copper strap is grounded to the back of the radio.
David Kaun
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
LaserDude wrote:

What exactly is the problem you are having? Did you change the head unit and still have poor sound just the same?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

If you are having problems with an aftermarket radio why not contact the company that makes the radio for help?
Glenn Beasley Chrysler Tech
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
On Sun, 05 Nov 2006 00:30:50 +0000, LaserDude wrote:

Hmmm...I changes the head unit to my '94 with no problem. However, on my '92 G V'Ger, there was another black wire that needed to be connected for the amps to turn on properly.
Did you get a Chrylser adapter from Scosche or such? Make sure all the wires are connected. If you have a hanging ground, that would cause your troubles!
Good Luck!
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.