Infinity stereo

'94 Caravan has the infinity stereo with tape player and equalizer. Unit works as it should in warm weather, but when it gets cold out the radio will not play, and the 'tape' icon is lit up on the display
although there's no tape in it. It appears that the unit senses that there's a tape inserted, which causes the radio to be cut out since it's trying to play a tape -- and, since there isn't one -- it plays nothing. After the vehicle's interior temp warms up, the unit performs as it should.
Does anyone know if this is a common problem with these units? I have located another one in the local salvage yard but don't want to switch them if the replacement one is likely to do the same thing.
It's my son's van and he has talked about getting the original unit repaired, but I don't know how feasible that is, nor where exactly you could count on getting it done right and at a reasonable cost.. TIA
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Common problem for a 13 year vehicle? The radio has an internal problem, R&R for repairs or replace the unit.
Glenn Beasley Chrysler Tech
-- Message posted using http://www.talkaboutautos.com/group/alt.autos.dodge / More information at http://www.talkaboutautos.com/faq.html
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.