Modules

Ok 95 intrepid 3.5l 24 valve. Which is the powertrain control module? the one under the air cleaner or the one beside the battery? Also just cleaned
battery terminals last week and corroded again this week. Bad ground?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Dear Blueeyes What's wrong with you vehicle that has you poking at the PCM?
Sincerely Glenn Beasley Chrysler Tech
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
to MAXPOWER The damn thing Quits at speed (automatic shutdown) Will not idle,(crank or camshaft sensor) Surges at speed (fuel pump or sensor). Does not downshift properly (transaxle speed sensor) runs rough starting and misses at speed. (Injectors or other sensor) Power brakes not getting boost all the time. (brake sensor or vacuum problem) A/c and heater controls work on occasion(buttons do not light up or work) but if not blower motor runs and throws heat. signal and hazzard flasher lights not working replaced flasher still problem then recently they have been working. All the problems above are intermitent and not all at the same time. Now 7 months ago I hit a deer, drivers side front no front end damage but front fender and door were wiped out. Inner and outer fender and door skin replaced. Before the accident only problem was slight surge which I assume is a sensor but all the others are since. Now trying to find parts for the 95 3.5l 24 valve with 16 in wheels and p225 r60 tires is a problem its the one with the rear wing and gold accented aluminum wheels. Very rare in Canada. I have seen 3 in the past year.So when phoning wrecking yards for parts knowing which module is which would help. I have the one beside the battery. Oh the only fault code that shows up is the low speed fan ground fault. Any help would be greatly appreciated
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Not a PCM problem, You have an electrical problem, possibly a bad ground and possibly due to the accident. Have someone check the area where the damage was. make sure all grounds are clean and tight
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Mr. Maxpower thank you very much. I forgot to add in my ramblings yesterday that I had cleaned the battery terminals two weeks ago. Yesterday when I lifted the hood they were all corroded again. Now things are much clearer. I signed up for this forum hoping to save some money because the PCM is a $1000. fix on my car. I would still like to know which module is beside the battery. Thanks again for your help I will post when I can get the car in.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Chrysler moves things around so much and it has been awhile since I worked on that year vehicle. If my memory serves me right (and im over 40) the PCM is under the air cleaner on that year (Black plastic module) and the trans controller is next to the battery ( alluminum module)
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Glenn thank you so much. Checked out the connections on the battery found ground to body cable under the battery was corroded and loose. Probably from my meeting with deer and most of the fender missing letting in the winter sludge. I have another question which I will post after so as not to confuse anyone who may be following along. Again thank you so much. Rick
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.