pain2001 Grand Caravan

I have a 2001 Grand Caravan, 3.8 engine, 128,000 miles. My problem is after going through a water puddle or car-wash the following problem occurs. In "drive" postion the radio, wipers, power windows, locks,
heater, all quit. Shifting to "nuetral", everything comes back on and works fine. Going down the highway, I have to shift to "nuetral" and coast in order to work heater, wipers etc. My dealer has had the car for the last week and cannot pin point the problem. They now recommend a whole new wiring harness for the tune of $1400 or $2200 installed. Has anyone experienced this problem and what was the cause? After drying out for 2 hrs in a heated garage, all systems work fine again.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
On Feb 28, 10:11pm, snipped-for-privacy@gmail.com wrote:

sounds like the dealer is trying to rip you go some where else and have them put the car on the computer sounds live water is hitting the computer or there is a plastic sheild missing to protect some vital parts like the dealer did not replace or some yoyo shop you went to for a tune up happens all the time with rookies
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.