'03 Dodge Ram automatic "noise"

Has anyone had a problem with the automatic used with the Hemi engine? By that I mean a failure of any sort. Mine has a sound I can best describe as sounding like a valve opening
and closing rapidly. Happens when the transmission is close to a downshift but not quite ready to do so. I've been assured by the service department it's common and not a cause for worry. It happens in 3rd, 4th and 5th. HD in NY
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
HD in NY wrote:

Judging by the lack of responses, I guess no one has had any failures. Has anyone else experienced the same noise from this transmission then? HD in NY
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I had a '05 Hemi Durango rental for a week last month. I didn't notice any transmission noises.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

I've got an '04 Hemi automatic and I haven't heard any tranny noises. Sorry I couldn't be more help.
Ron W.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
RW wrote:

Thanks. I'm told that the '03 transmission does this but doesn't cause any harm. Since I questioned the service department about the noise, maybe I'm covered. I also tow a 30' trailer with it and it does it either towing or solo.It also unlocks and locks several times while towing and going up a slight grade (like overpasses). This with the OD locked out. This also is "normal" as per the Chryco Service Manager. HD in NY
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I've got the '03 with Hemi and auto: Haven't noticed the noise. I also pull a 28' trailer and haven't noticed it unlocking and locking (I assume you mean some sort of "hunting" type feeling) Unless i forget to lock out the OD.

Sorry
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
US wrote:

snipped
Sorry I forgot to thank you for your response. One quick note on the unlocking. It only does it with OD locked out. If I leave it in OD, the transmission will shift from 5th lockup to 3rd unlocked on a grade. This is with cruise on and engaged. HD in NY
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
US wrote:

snipped
Thanks. I've got to get the oil and filter changed again soon. Guess I'm going to have to pursue this again with the Service Manager. I've checked to see if there was a computer update for it but haven't found any. The noise isn't real loud but is annoying, plus any noise from a transmission or engine is cause for concern.
Wish Mike S. would chip in on this. HD in NY
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

HD:
I just saw your post... email me with your details.
Mike

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.