1993 Dodge Dakota 3.9l V6 backfires when hot

I have a 1993 dakota p/u when hot within 10 minutes or so it will start to back fire and eventually dies and will not start till it cools off. I have
changed exaust, cathalytic converter & EGR valve on recomendation of my mechanic but the problem still there. also when i close the hood sometimes it shuts off from the vibration. Any idea or sugestion greatly appriciated.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
hghg wrote:

Does it run smoothly before it begins to backfire? Does this come on all of a sudden?
--
Ken



Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
It starts smooth after 10 or 15 minutes it srarts to back fire and eventualy stops alltogether.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
hghg wrote:

I know you already changed the valve but it still sounds to me like an EGR problem. Check all the hardware, hoses, and tubes on and around the EGR system again. Check /all/ the vacuum hoses under the hood too.
--
Ken



Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
check the pickup coil distributor larman

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.