1998 2500 wiring problems 1964 to 1998 frame swap

I have a 1964 town wagon I put a 1998 Ram 2500 5.9L (360) with a 5 speed frame under it. I am Having problems with the wires. I would like to know what wires I need to get it running. I saved as much of
the wiring as I could. I have most of it at least I thought I had everything I needed. The 1998 did not have a fuel pump in it when I got it and the pig tale was cut off. I put a fuel pump from a 1997 ram van in it and wired in the pig tale. My first unknown I do not know if I wired it in right. The pig tale on the 1998 had 4 wires (Black with blue stripe, Blue with White stripe, Green with black stripe, and a Black). the 1997 van had (Blue no stripe, Green Black stripe, and two Blacks the tied together) I conected the blue blue stripe to the blue no stripe and the green black stripe to the green black stripe and the black to the blacks. I do not have any Power to the Fuel pump and no Power to the Stater selinoide. But If I give it a shot of eather and put power to the starter it will try to run for about 5 seconds. I think it might run if I had fuel. Does any one know what wires should have power at the fuel pump. Or know how I can wire up the pump to get it to pump fuel.
Thanks I am also going to order a Factor service manual but I thought some one might be able to help.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.