1999 dodge ram 1500 engine problems

I have a 1999 dodge ram 1500. It will start and idle just fine but when I put it into gear it dies.What could cause this? Thanks!

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
If you give it gas when you put it into gear will it go??? WHen was the last tuneup ?? Assuming the motor runs good ? It could have a problem with the lockup torque converter
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
On Jan 24, 1:58 pm, snipped-for-privacy@yahoo.com wrote:

What happens if you don't put it in gear, but give it the gas while still in park? Does it speed up quickly like you'd expect, or does it miss?
If it misses above idle with no load, I have on at least one occasion seen this clear up with a new battery. Monitor your voltage during these tests, be sure it hangs around 13-14 or thereabouts.
Martin
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

I have the same problem but it runs well while in park and only does this when the engine is cold??? Any other thoughts on this would be appreciated. JP
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.