1999 Durango Rear Power Windows

Both rear windows have quit working while both front windows still work fine. I have checked both rear windows and have 12 volts going to the motor. Is it possible that both motors went out at the same time or do
I have something else going on?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

if you are probing both the wires going to the motor with your meter and your seeing +12v and -12v when switching to up and down then yes i would say that most likely you have two bad window motors.
--
-Chris
05 CTD
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Christopher Thompson wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
My left rear window did the same thing. I thougbt "oh no, my window motor went bad". Out of aggrevation, I kept hitting the down direction on the switch and herd it break loose. I don't think anything sticky got in the seal, but for some reason, probably lack of use, it just stuck. No problems since. I'd try helping them down with your hand to see if they aren't just stuck to the seals.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.