2000 ram 1500 ABS Brake Speedometer problem

I backed into my tractor with my 2000 Dodge Ram 1500. Put a dent in the tailgate but it works ok. Later, I noticed that the ABS light was on and the
brake light was on. I drove about 10 miles and the speedometer quit working. What could the dent in the tailgate have to do with all that? I took the battery loose for a bit and put it back on and the lights still stay on. Any suggsetion or solutions?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

I had similar symptoms quite recently. ABS and brake light on, and speedometer working only at high speeds.
You can check your engine code with a code reader for more definitive diagnosis.
In my instance, it was a bad RWAL (rear wheel antilock) speed sensor.
Replacing it took care of the problem. I bought my replacement online.
i
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

A dented tailgate? Nothing. However, you might have also hit something with the rear axle, and damaged the wiring to the speed sensor. Check out the wiring and connector that goes to the sensor on the top of the rear differential.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

I agree could be the speed sensor. Watch out when trying to remove, it breaks easily and pain in the arse to remove if you break it.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Now, I see that my gas mileage indicator shows me getting 20 to 22 miles per gallon, rather than the 13 - 15 mpg. I may just leave it this way. Look how much I am svaing on gas...

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
your vehicle speed sensor is not working properly. I had the same symptoms in my 98 ram. I let it go for a while thinking nothing of it. I later spent $2500 for a new transmission. After the fact I found out that had I had it looked at it would have only cost approximately $300 to solve the problem. Get it check out soon! Also the computer doesnt throw a code for it...
CeeBo
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.