2000 Ram A.C. question

I have a 1500 Ram,5.9 auto, 2000 , 75,000 miles
The AC is not cold at all. The AC line that goes into dash (aluminum line) is very cold, zero deg or less.
The Low side presure is around 40 psi, don't have gauge to check high side. Compressor cycles 3 or 4 times a minute.
Clamping off heater hose makes no difference. Cruise Control works (seen that posted here as a symptom of a vacuum leak.)
All heater functions work and temp is changeable on heat side.
Is this a problem with the Heater /AC controls?
Thanks
Gary D.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Sounds like a problem with the blend air door.
--
If at first you don't succeed, you're not cut out for skydiving
"dingy101" < snipped-for-privacy@dinges.com> wrote in message
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
If the blend door is at fault wouldn't this also affect the heat side as well? The heat side works OK. Temp is changeable on heat side.
Gary
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
IT should but that depends on how and where it broke. The easiest test is to check the output temp first thing in the morning with the engine dirt cold before the sun or the heater core has a chance to warm things up. Set it to full cold and start it up and check the air temp. If the airflow is cooler than the outside air, then you probably have a problem with the blend air door. It may be broken at the cable attachment point where the cable can push it to the hot side but cannot pull it past the midpoint to the cold side. It could also be some crap plugging up the evaporator fins and not letting the air pass through it but if that is the case, I would suspect that you would see a reduction of airflow at the full cold position.
--
If at first you don't succeed, you're not cut out for skydiving

"dingy101" < snipped-for-privacy@dinges.com> wrote in message
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.