2001 cooling fan

I have a 2001 GRAND CARAVAN with a 3.3 the cooling fans will work when I wire them directly to the battery not any other way. I have also changed the cooling fan relay 3 times and it still dosen't work can any
of help? THANKS jaywd2
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Temperature sensor is next.
FMB
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I changed the temperature sensor and they still do not work. Any other suggestions THANKS jaywd2
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Have you checked your wires for continuity?
FMB
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Yea, get the wiring diagram and see what actually decides when to turn them on and make sure that is still functional. Is it the computer, the temp sensor, or whatever? I would also check those fan relays and make sure that they have power are still functional. Just because they click (if they are still moving) doesn't mean that they are still making a connection and if there is no power for them to switch, it really doesn't matter if they are functional or not as nothing will happen anyway.
--
If at first you don't succeed, you're not cut out for skydiving

"jaywd2" < snipped-for-privacy@yahoo.com> wrote in message
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
==========jaywd2 wrote:

============ 1) Check for power and ground at harness connector at the fan.
2) Check for power coming OUT of the relay.
3) Check for a ground signal going INTO the relay.
The ECM sends the ground signal to turn the relay on. No ground signal, no fan.
Use the above 3 checks, post the results.
Do a google...the fans elect. schematic is out there. I know it's archived in this NG, I've posted it before.
~:~ MarshMonster ~google is yer friend~ ~:~
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.