2001 Dakota 3.9-Couple questions/problems

Howdy all, I have a couple of strange questions/problems with my 3.9 Dakota 2001 model...
Starting-It seems to take 4-7 seconds of cranking to start,I have a ranger
that starts within 2-3 seconds of turning the key.Is this just the norm with the 3.9 engine? I am just used to things turning over quicker.I changed the plugs and wires yesterday,which were quite worn hoping it would fix the problem but its still the same,I really dont know if its a problem or if I am just impatient and used to other vehicles.
Another thing,in reverse,when backing up slowly,the engine seems to run rough and even has stalled a few times.Doesnt happen in forward,only in reverse,like the idle isnt high enough to keep the engine running.
Any ideas or comments? Thanks Rob
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Try cleaning the throttle body. If that doesn't work, there is a sensor inside the intake manifold that may be dirty and need cleaned. If you pull the air cleaner and associated plastic piping you can just barely see it with a flashlight. Spray throttle body cleaner in there really good and clean it with a lint free cloth, or just have it replaced.....bout $200 at a shop. Joe

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Throttle body cleaner the same as regular carb cleaner?

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
pretty close, but actually a little safer for the man-made components. Just make sure the engine is not running as you initially spray it in the throttle body. Use a good amount then look for the sensor inside the manifold area; this is where you want to direct the next part. Start the engine. *** Don't get over enthusiastic with this part*****Then only use very short bursts. You'll notice the engine stall and black smoke will come out the tailpipe. If you spray it full out you can damage the O2 sensors. The cheapest O2 sensor is $73, so short bursts are in order. Wait for the engine to smooth out between shots. After a dozen or so shots to the throttle body with the engine running, shut it down and look for the sensor I told you about earlier. It should look clean. If not you can clean it some more or take it to a shop...... Hope this helps, Joe

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Just in case, can the sensor be rplaced or does the whole throttle body get replaced.
If it needs the whole thing,is it something anyone can do or is it an involved operation?

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Well I opened the throttle up all teh way but cant really see any sensor there,which side of the truck would i be looking towards to see it?

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
If you have the time and a torque wrench, you can do the job. You'll have to pull the intake manifold to get to the sensor, so a Saturday is in order. It's pretty straight forward, just get a Haynes manual and "have fun". Most likely just cleaning the throttle body really good will solve your problem though. Joe

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Which direction is the sensor i am looking for located when looking into the manifold?

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.