44RE eratic shift problem

I have a 99 Dodge Dakota 4x4 with the 3.9 V6 and 44RE auto trans. w/ OD. I purchased the truck with 51K miles on it. At around 55K the trans. developed an eratic shift from 2nd to 3rd. It seems to me that
the shift starts too early and slips too long before going into 3rd. All other gears are fine. I thought I had read a thread a while back describing a fix for this, which seems to be a common problem with this transmission. But, I did a search and can not find the thread now. Any help would be greatly appreciated. Thanks, Mike
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
On 14 Apr 2007 08:51:36 -0700, snipped-for-privacy@comcast.net wrote:

and look under shift concerns w/o all the pomp ass the airhead gives out
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
====== ====== On Apr 14, 1:37�pm, snipped-for-privacy@aol.com wrote:

======
me.....i wudda jest said ck the 2-3 accumulator and servo.... and provided a link.
but.....to each his own.
~~ 00 L O
nice link though......where'd you find it??
:)
~:~ MarshMonster ~sips his mushroom tea..takes a toke...~ ~:~
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Spray the kick down cable ball swivel at the trans. They stick intermitently.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.