5.9 Cummins Belt Squeal

Hi Group!
Have been having a squealing noise coming out of the front right side of my 99 CTD. Each time the belt is changed the squeal goes away for awhile but
seems to always return.
On the third belt now in the past several weeks.
Anyone in the group have any similar experience and maybe found the cure?
TIA
Fred
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
most likely an idler pulley bearing

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

on.
Ken
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Thanks Ken will give that a try ...
Fred

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Is the squeal while it is running or just when shutting down?
Only a just-installed serpentine belt will not squeak for a week or so... then it will squeak because of the inertia of the accessories when the compression of the engine stops the engine.
The squeak is pretty normal unless it happens when the engine is running.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.