'97 Dakota 3.9liter V6 coil issues

My truck has had this problem for years but only intermittently where it just suddenly loses power. Sometimes it will start right back up, other
times not. The 1st incident was diagnosed as a bad fuel pump by the Dodge dealer and I replaced that. All seemed well for several months and then... The 2nd incident shortly after that came up with a code indicating a faulty primary coil. The coil was replaced and all seemed well for 2 years and then the problem started to reoccur. I replaced the coil less than 2 months ago and again, all seemed well. I was running errands last night when after the 3rd stop it just refused to start and/or stay running. I had driven the truck less than 5 miles and over the course of maybe 10 minutes. I immediately jumped out and checked the coil, no loose wires and the case itself was cold . I let it sit over night and tried to start it, same problem..It would fire but not stay running so I swapped out the coil with the one I had pulled off it last time and the truck started right up and drove flawlessly.
I have an ODB scanner and its not showing any codes. Any clues whats going on??
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
bad connection in that area? broken wire inside the insulation? no idea - just suggesting a couple things I would check for. Intermittent connections can come and go with movement and heat and are a beotch to locate.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.