99 1500 Ram ocerdrive problem

Ijust purchased this truck and at about 60 mph it wants to shift in and out of overdrive constantly with very little torque on the engine. Any ideas?
It seems there might be an easy solution with a new sensor or ?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Blammers wrote:

Can you feel it actually shifting, or are you noticing about a 200 rpm jump up and down ?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
It shifts
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Most likely, what you're feeling isn't a 4-3, 3-4 shift, but the torque converter locking and unlocking. Two common causes of this are a bad throttle position sensor (TPS), located on the throttle body (on top of the intake manifold), or a bad brake switch, located on a bracket alongside the brake pedal arm. Both are easily checked with a voltmeter (an analog meter is better for testing the TPS), and both are inexpensive (and simple) to replace.
There are other possibilities, but these are the most common.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Thanks..I will check.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
mine was doing the same thing last week. it should be out of the shop tomarrow. transmission rebuild
--
Billy K
95 Ram 2500 Cummins 4x4
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
yes they are! but when they are right :) actually I think the dodge automatic is the weak link in all their 90's on trucks, but due to a handicap it is easier for me to have the automatic.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Yeah, I just bought one a couple months ago and I've noticed mine doing it with the cruise on. I don't really use CC but it would be nice to have it working for when I do want to use it. Thanks for the info.
wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.