99 dakota sport V-6 4x4 abs/brake light stays on

Hi all,my abs/brake light stays on.At first it would only be on awhile and when you turned off the engine and started it back up it would stay off. Now it stays on.I also noticed the speedometer doesnt work untill you hit
about 30 miles per hr.I took it to a shop and they used a hand held checker to test it. It shows 2 errors:72,71 ecu rom checksum error and 71 is ecv ram rod wright error. The guys didnt know what this means. Anyone got any ideas? Thanks!
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
From what I have read it's a speed sensor located in the rear differential. My Dakota has the same symptoms and I believe it's fairly common. I haven't repaired mine yet, but they tell me the part is $35.00.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Fellas:
Just out of pure luck, I replaced mine this past Saturday. I've got a '99 Durango. It showed the exact same symptoms. I didn't even bother with the codes, figuring it was cheaper and easier to try replacing the sensor.
The part was about $35 from dodgeparts.com. It took me 20 minutes to install. The problem went away immediately. On the Durango, the sensor was pretty easy to reach. I didn't even jack 'er up and didn't have to remove the spare.
--Phil
Glenn wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.