Cruise control question

I have a 2000 Dodge Ram 1500 Van, V8 5.2L. When I press the cruise control switch, I see a green "Cruise" light on the cluster. But the cruise doesnt work.
I checked the fuse boxes, both next to the brake booster and the one next to the instrument cluster. They dont seem to have a fuse for the cruise control.
What should I look out for next ? Any tips will be appreciated.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Condition of vacuum lines going to the cruise control unit - or a vacuum leak somewhere else in the system.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Check the cruise control throttle cable
Ken W
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Did you just buy the vehicle or have you had it and the cruise control stopped working?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

I just bought the vehicle and it wasnt working then.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

I was asking because after I bought my truck I was fumbling around around with the cruise control and it was not working either. Till I figured out I was not hitting the buttons correctly. I have had many cruise controls also. It seems they all work differently
I finally pushed the cruise ON/OFF button, saw the cruise light come on then pushed the SET button and it engaged. But that was just me, maybe you did as I did and thinking it was not working
GB
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.