Dodge Durango Core Plugs

I have a 2000 Dodge Durango with a 5.2L Magnum engine. It has 42,000 miles. On March 29, 2005, it started leaking anti-freeze coolant from the bottom of the truck. I took it to the dealer (since it might be a
warranty fix), and they indicated that 3 of the 16 freeze (core) plugs were leaking due to rust. Luckily, this is still covered since I am under the 50,000 mile warranty for this part. My problem is that I am having a hard time understanding how could this rust so easily and so quickly. I have never put water in the radiator well, just coolant a few times to top it off. I have never flushed the system since it's not time yet and I follow maintenance plan which says to do this at 50,000 miles. Is this a design problem with the SUV Truck? Thanks for your responses in advanced.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I will never understand by now why the manufacturers are not installing brass plugs from the factory. I just replace 3 of the 6 on my 1983 F-250 and not sure how to get one of the three on the other side without removing the engine. These things just seem to rust no mater what you are running in the radiator.
Ron
JoeySamone wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.