Low oil Pressure

oil pressure problem here, when i start my truck for the day its a 1990 Dodge d200 360 engine. The oil pressure by the gage is fine however after a short drive on the highway into the city the oil
pressure drops on the gage and the light comes on. This only happens once the engine is fully warmed up. any ideas out there?
--
Posted using the http://www.autoforumz.com interface, at author's request
Articles individually checked for conformance to usenet standards
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
What weight of oil are you using and how many miles on the engine?
--
If at first you don't succeed, you're not cut out for skydiving


"randy_ca" < snipped-for-privacy@AutoForumz.com> wrote in message
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
randy_ca wrote:

How many miles on the truck?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

First thing to do is remove the oil pressure sender. It's way in the back by the distributor. Hook a regular mechanical gauge to the port where the sender was and see what's really happening. The oil pressure sender could be the problem. My 92 360 is on it's third. The first replacement I bought started leaking after about a year.
Al
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.