P 0201 '03 HO

I have gotten this code usually after (or during) WOT to get on the freeway. Engine seems to run smooth when not excellerating but seems to miss at WOT
or even accellerating at less than WOT. P-0201 = Fuel Injector 1 Circuit.
I've cleared the code and the truck runs fine till I WOT a few times. It doesn't always happen with the first WOT but it has occurred 3 times in the past week.
Is there anything I should look at before taking it in to the dealer? Almost 98k miles on it, original fuel pumps.
Along with that code I get the P 0633.
TIA FMB
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Nah - you're still under warranty (just), so get it to the dealer before you roll 100K, at least to get the problem documented. Anything fuel-injector-related can run into significant $$$. Hopefully, you don't have any aftermarket boxes or programmers installed, and can present a completely stock engine to the dealership for diagnosis/repair.

Do you have the Sentry Key system? (Big thick gray-handled ignition key) - if so, it's not working. Tell the dealership about that, as well. That's just a simple programming task to reset the encryption key in the PCM
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Thanks Tom. I do have the big thick gray-handled ignition key. My aftermarket items include pyro, fuel pressure and boost guages.
FMB
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.