rattle during start

Hello, long time lurker/leaver/justcame back for help
Recently when I start my truck, (2000 1500 4x4) I get this rattle in the (i think) transmission about 5 seconds after I start the truck and then it goes
away after 3 seconds. I makes this noise no matter if it is in park, reverse, moving forward, etc. Just when I first start it. I fell no performance issues, it shifts fine, drives fine, just a loud rattle when starting up, then it smooths out. the only time i can make the sound change is if I change the shifter for the 4x4, but it still does not go completely away. If I rev the engine at first start it waits untli the rps drop back down and then it does the rattle.
any clues? thanks
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Heat shield at converter.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Or the converter itself.
--
If at first you don't succeed, you're not cut out for skydiving
"Roy" < snipped-for-privacy@home.net> wrote in message
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
If the noise alters with the 4wd lever, check the linkage to the transfer case. Otherwise, my first thought is also the cat converter shield or the cat itself.
--
Max

Join www.devilbrad.com and find out what free exchange of info is all about.
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
yes, I accidentally found out today it was definately coming from the exaust somehwere. was cleaning the chrome pipes and i heard the rattle. maybe not the cat but somewhere along that line.
I think when 4wd was engaged the vibration was just different, so it did not rattle as much.
thanks!

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
If it's coming from the exhaust, then it is either the cat or the shield.
--
If at first you don't succeed, you're not cut out for skydiving
"EDTHEWARD" < snipped-for-privacy@BLARG.NET> wrote in message
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Sounds like your exhaust to me . Might be a loose exhaust hanger or something. I could be wrong though.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.