turn signals

Have 97Ram1500, 5.9, auto, 2wd. This afternoon I lost all turnsignals, including dash indicators. Went from everything working to nothing working. All other electric fubctions ok. Fuse? Relay?

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
It sounds like the flasher unit failed.
--
If at first you don't succeed, you're not cut out for skydiving
"Mr,Lou" < snipped-for-privacy@adelphia.net> wrote in message
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Suddenly, without warning, Mr,Lou exclaimed (28-Dec-06 2:44 PM):

How about the radio? When this happened to my truck, intermittently, the radio went out with the turn signals... turned out to be the ignition switch (diagnosed by someone here). Try wiggling it and see if the signals come back...
jmc
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
jmc wrote:

The radio works fine. That's what so strange, all electrics other than turn signals are fine. Allother dashlights, interior lights, radio etc. ok.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Why is that strange? If the flasher unit fails, the only thing that will not work are the flashers. Replace the flasher. You will find it next to the fuse box behind the kick panel.
--
If at first you don't succeed, you're not cut out for skydiving
"Mr,Lou" < snipped-for-privacy@adelphia.net> wrote in message
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.