1978 Fiat Spider Making Weird Noises

Hi, I just got a 1978 fiat spider about 3 weeks ago and its great, but I just had my first major problem. I was leaving a parking lot in first gear and I heard a loud WHAM! It
sounded like two pieces of metal slamming together right underneath my car in the center. I continued for a minute with problems, but after a redlight when I accelerated again it made the noise again, 3 times. After this I pulled over and peeked under my car and didn't spot anything immediately wrong (for example a zombie dragging under my car ). I drove the rest of the way home very slowly and didn't hear any more of the loud slams, but whenever I was moving and went into neutral and coasted I heard lots of little clangs (about 5 clangs a second the entire time I coasted). Any idea what might have caused this sudden problem and how to go about fixing it. Also, if it something I could easily fix, how much would a mechanic charge? Thanks for taking the time to read my post.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Check your engine mountings -
Open the bonnet and make sure the engine is where it should be!
Paul

redlight
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
TipSpider wrote:

sounds like propshaft
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
sounds like the universal joints on the drive shaft.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.