heater blowing cold

the heater in my uno is blowing cold all the time but the engine is getting hot in fact the fan is working over time. i read that even if the thermostat is capput, the heater should still work
as it draws its hot water from the engine block. also it seems the auto choke is not shutting off correctly. please dont say its the head gaskit.:(
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
On 29-Nov-2003, snipped-for-privacy@zworg.com (pugwash) wrote:

Heater tap/valve or its linkage kaput. Hoses collapsed or kinked. Blocked water system after someone has used RadWeld or similar. Faulty thermostat more commonly results in over cooling, but stuck shut can't be ruled out. In the winter at these temperatures the fan shouldn't cut in very often. If you have acess to a garden hose then I'd pick a fine dry day and flush the system, with a working heater tap in the open/hot position. Radiator is easy to remove, fill with water and shake vigorously, then flush through. Undo the heater feed hose and see if water goes through it, may be a gunged up heater matrix. Often the bottom few tubes are blocked with sediment, they are quite small in cross section, yours may be mostly or all blocked.
Curious about the auto choke, Uno's I've met, both Mk1 and the later Mk2 are manual choke, what year is yours?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
(pugwash) wrote:

my uno is L reg its clear to see that someone has added the auto choke as there is just a hole where the manual was. would it be worth changing the thermostat first as i imagine that would be the easier job. am a bit confused cos i read that even if the stat is not working the heater should still work as it draws its water from the block?? having said that , i once had a viva that had the same problem so i changed the stat and it worked fine so maybe its a different system for the fiats? thanks anyway.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.