Tipo 1.7 D lost its power

Hi everybody,
the Tipo I drive, 1.7 diesel has 172.000 km, all filters and engine oil are being changed on regular basis; injectors were replaced at 150.000 km.
Now the car lost its power at acceleration, when being just minimaly loaded or driving uphill; the top speed reduced from 160 km/h to 140 km/h. Satisfying power can be achieved only on high speed of the main engine shaft rotation (e.g. driving in 4th insted of 5th gear) or/and full gas. The power lost did not appear over night, but it is obvious and it is more perceptible in very hot weather (more than 25 deg. Cel.) There is no engine oil consumption or any black smoke from exhaust. The car simply does not have the power anymore from unknow reason. The fuel consumption did not increase heavily. After fuel filter being replaced (advice from a mechanic) there is no a positive change.
Thanks for help, explanations, solutions !
Best Regards, Klemen
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
MAF sensor ??
Almost exactly the same symptoms on my Marea recently.
Graham
<DIV><FONT face=Arial size=1>&nbsp;Hi everybody,</FONT></DIV> <DIV><FONT face=Arial size=1></FONT>&nbsp;</DIV> <DIV><FONT face=Arial size=1>the Tipo I drive, 1.7 diesel has 172.000 km, all filters and engine oil are being changed on regular basis; injectors were replaced at 150.000 km.</FONT></DIV> <DIV><FONT face=Arial size=1>Now the car lost its power at acceleration, when being just minimaly loaded or driving uphill; the top speed reduced from 160 km/h to 140 km/h.</FONT></DIV> <DIV><FONT face=Arial size=1>Satisfying power can be achieved only on high speed of the main engine shaft rotation (e.g. driving in 4th insted of 5th gear) or/and full gas.</FONT></DIV> <DIV><FONT face=Arial size=1>The power lost did not appear over night, but it is obvious and it is more perceptible in very hot weather&nbsp; (more than 25 deg. Cel.)</FONT></DIV> <DIV><FONT face=Arial size=1>There is no engine oil consumption or any black smoke from exhaust. The car simply does not have the power anymore from unknow reason.</FONT></DIV> <DIV><FONT face=Arial size=1>The fuel consumption did not increase heavily. After fuel filter being replaced (advice from a mechanic) there is no a&nbsp;positive change.</FONT></DIV> <DIV><FONT face=Arial size=1></FONT>&nbsp;</DIV> <DIV><FONT face=Arial size=1>Thanks for help, explanations, solutions !</FONT></DIV> <DIV><FONT face=Arial size=1></FONT>&nbsp;</DIV> <DIV><FONT face=Arial size=1>Best Regards,</FONT></DIV> <DIV><FONT face=Arial size=1>Klemen</FONT></DIV></BLOCKQUOTE></BODY></HTML>
------=
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Graham, what is MAF sensor?
Jacek
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Graham, what is MAF sensor?
Mass Air Flow sensor
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
MAF sensor ??
Almost exactly the same symptoms on my Marea recently.
Graham
As Bartoz says further down, it's the Mass Air Flow Sensor (or meter sometimes). It measures the air coming into the engine, then the ECU calculates the mixture etc to make it run nicely. Over time, it can get dirty/gunky, and just stop working. Some say you can clean them but I don't know.
Cost me 200gbp, or around 300 Euros for the part alone. - Might be cheaper on your car (especially since you don't appear to live in the UK !!)
Take it to a dealer, and plug it into the computer.
Hope this helps
Graham
(May also be other things too !!)
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Thank you for your answer. Graham, I don't know what kind of engine is using Tipo. I am driving Punto. It has 1,7TD motor without any computer. It has small microcontroller only to measure the temperature of the engine and to switch on and off preheating (I don't know proper English word, I hope you understand what I mean ;) ). In my opinion Tipo has near the same engine. Your Marea has brand new TDI common rail diesel engine. It is diffrent - it is better, I think. I hope ;-)))
Jacek
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Hi again, I checked your replies today, thank you! Well, the my Tipo diesel engine has no such kind sensors at all, it's an old and simlple design engine, so there is no electronic at all and it is not a common rail diesel engine. It is not even a turbo diesel ;(
If anyone has some more ideas, you're welcome!
Best Regards, Klemen
If you have a

Thank you for your answer. Graham, I don't know what kind of engine is using Tipo. I am driving Punto. It has 1,7TD motor without any computer. It has small microcontroller only to measure the temperature of the engine and to switch on and off preheating (I don't know proper English word, I hope you understand what I mean ;) ). In my opinion Tipo has near the same engine. Your Marea has brand new TDI common rail diesel engine. It is diffrent - it is better, I think. I hope ;-)))
Jacek
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.