700R4 won't do Overdrive ?

I've got an '84 Camaro, Z28, with a 305 H.O. engine, 120,000 miles. A couple of days ago, while driving in Overdrive, I heard "clunk" noise and
the engine just started spinning like it was in neutral. Fortunately, 1st, 2nd, and 3rd gears got me back home. But now I think I'm faced with buying a rebuilt tranny (about $1,500.00). What really nags at me is the thought that I might somehow be able to fix the problem by replacing some $10.00 part (IF I knew which one). Which leads me to a couple of questions A) Does anyone have any ideas on what the cause might be ? B) Does anyone have experience with Accurate rebuilt transmissions or Jasper ? Thanks.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Addendum: I took a more careful test drive. It turns out that I do have 4th gear, but only if I manually put the shift into Overdrive at about 40 mph. If I step on the gas fast and the tranny needs to downshift, I loose all drive in the OD position. So whatever connects me to 3rd, 2nd, 1st gears from the OD position seems to be out. Any clue as to what that item is ?

1st,
buying
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Hopefully I can explain the powerflow in your transmission. To get output from a 3 piece planetary gearset, as your transmission uses, one gear needs to the input (driven from the engine) and another needs to be held to the case. If one doesn't hold or the driving member (clutch) slips you get neutral. In second gear the band is holding and the forward clutches are the driving member. To get direct drive or 3rd gear, the forward clutches and the 3/4 clutches are driving to "lock" the gearset. In fourth gear the band is holding and the 3/4 clutches are driving. So slippage in fourth means either the band or the 3/4 clutches are failing. If you manually put the shifter in 2nd and 3rd you should be able to duplicate the problem confirming either band or 3/4 clutch failure. Many times in the 700 trans, if it fails to upshift into 4th it is caused by a sticking shift valve in the valve body or a loose "head" on the governor assembly. Other problems with the governor will cause it to go to 1st gear. You might want to pull it out and check the gear and the weighted end.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Check summitracing.com or jegs for trannys. you can get a much better tranny from one of them for the same money. b&m $1650 & tci is $1300 for lockup and $1500 for non lockup.

1st,
buying
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I've got several TH700-R4 trannys in various vehicles. I get great service using GM Tranny for 1987 350 H.O. IROC-Z. Has 3 year or 36,000 mile warranty. Cost is about 1350 Exchange. Unit will also will stay in overdrive at top speed.
wrote:

----------------------------------------- Posted via abcusenet.com. Check us out at http://www.abcusenet.com -----------------------------------------
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.