91 firebird 3.1 V-6

My daughters 91 firebird quits and will not restart for a while. It will turn over but not start? I l went to pick up her car because she said it quit
on her again. We just had the ECM unit replaced, the mechanic thought that was the problem. I went to the car and tried to start it and it would only turn over. I winched it on to my trailer. I then went to turn off the key and thought I would try it and it started? Anyone have any similar problems? Thanks for your help.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Either a loose/broken cable or VATS (not sure if VATS allows it to crank)
Does the fuel pump prime ? Does it smell of fuel ? Have you checked for a spark ?
--
Mitch - 1995 Z28 LT1 M6 terminal snipped-for-privacy@sand-hill.freeserve.co.uk
Lancashire England http://www.sand-hill.freeserve.co.uk/terminal_crazy /
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Terminal Crazy wrote:

It would not be VATS as that would not allow it to crank. I would recommend checking the ignition module, fuel pump and the coil packs (IIRC the 91 v6 had coil packs already). It sounds like either fuel delivery or spark. You also probably should check the different sensors. One to check would be any/all crank position sensors, since if they fail once they get hot there would be no spark or fuel since the computer needs those pulses to time both spark and injectors. I know that the coil in the distributer in the v8's can go out and can show exactly those symptoms, but I'm not sure what takes it's place in the v6's as I don't think they have a distributer.
--
Cy Welch
89 Camaro RS 5.0 TBI
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
The fuel pump was replaced last year and has been working fine. And since it started at a later time I would consider your crank sensor to be a good idea. Is there a way to check the ignition module? Or is it a part you just have to replace and hope you get the right one?
Cy Welch wrote:

--
Message posted via CarKB.com
http://www.carkb.com/Uwe/Forums.aspx/pontiac-firebird/200703/1
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
The fuel pump was replaced last year and we have not had any problems with it. Another guy thought it could be the crank sensor. What is your opinion?
Terminal Crazy wrote:

--
Message posted via CarKB.com
http://www.carkb.com/Uwe/Forums.aspx/pontiac-firebird/200703/1
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.