98 Z/28 shaking/Vibration ???

I have a 98 Z/28 with about 58k miles on it. Had the oil changed at 57k. I am noticing that when the car idles in drive after driving on the freeway
some that it seems to "vibrate" to the point where you can hear it in your ears. It does this at 600rpm and only after driving on freeway for a little while. In town, or short drives it is fine and smooth.
Another thing is I am hearing a slight pop out of the exhaust on deceleration. I have only owned the car for a few months and have no idea on the service schedule of the previous owner. The car is stock except for a K&N filter. I am planning on changing to SLP Loudmouth this weekend.
So...any ideas on these 2 issues, maybe related? I was thinking of changing plugs and wires this weekend and seeing if that helps. I know my 'Vette popped when I had worn plugs, and a new set of plugs and wires made a world of difference.
The car does not seem to run adversely, it actually runs great! I dont even know if these 2 things are anything to worry about.
Thanx Casey
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Casey wrote:

Possible when the did the service the bent, cracked an exhaust pipe. Even a small opening could draw in air causing the pop as well as changing the accoustics.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.