99 Firebird radio display strangeness

This has been going on for about a year or so now both with the original radio and with a Pioneer that my son gave me from his 99 Firebird. What happens is that the display will blank and at the same
time the windows will not go either down or up. After a bit the display comes back on, the time is correct and none of the preset stations have been lost and the windows will work again. I had thought to attribute this to the Texas heat but when we changed out radios and it continued I dismissed that idea. I've pressed in on each of the fuses to ensure that they're all in tightly, this seemed to make a difference as it didn't happen for about a week, then it started again. Pressing in all the fuses this time didn't seem to make a difference. Anyone have any suggestions on what to check?
Chris
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Chris,
I have been having the same problem and I'm not certain where the issue lies. I believe there is a short or a ground issue somewhere, but I don't know where there is an interplay between electrical systems. Here's two things that seem to work sometimes - hitting the center console pretty hard, or unlocking and relocking the doors. I don't know what all that has in common with the windows being disabled.
If anyone has some ideas, I'd love to hear them!
Thanks, Ryan

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.