Advice Sought

Hi, I think my transmission is going out of my camaro. There other day I gave it alot of gas and suddenly smelled something burning. I saw smoke in my rear view mirror. It appeared to be coming from around my rear end
or tires. I put super torque fluid in it so perhaps it was too super for my torqing abilities? I used a torque wrench to bring it down a bit but it still smells like something is burning when I mash on it. I shifted the transmission in to (R),which I assume is "Race", to see if it still acted up but I believe the dealer installed my "Race" gear backwards because I slammed into a building behind me :( If anyone has any information I would be thankful. Thanks
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
It figures you are posting from webtv. That and your post says a lot about you. Piss poor attempt at humor mate. Don't sign up for any comedian contests.
On Sat, 17 Jun 2006 16:08:43 -0500, Doors06 snipped-for-privacy@webtv.net (W W) wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
You use 'D' (drag) to get moving quick, then 'R' (race) for top end. If it goes backwards, you might have had your torque wrench set on negative torque instead of positive torque. Don't even try to use 'P' (pass) until you get it fixed right. Duh.
-rev
W W wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.