belt noise

I have had my 1999 Z28 since new. My problem is that almost since day one there has been a loud squeaking noise from the timing belt, probably the self tensioner area. It has been into the shop, under waranty, twice for
this problem both times they changed the belt and "lubed things up" (their words not mine). Still the noise continues!! As I get older it is starting to really get on my nerves. I was wondering if this is a common problem with the LS1 engine in this car and if there is a satisfactory fix?
Please help before the squeaking drives me right off my rocker.
Paul
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

I assume you're talking about the serpentine belt, not the timing belt. You need to locate the sound and determine the actual problem, is the tensioner bad and does it need to be replaced? If the belt was replaced and the problem persists, it's more than likely NOT the belt.
-Bruce
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Check the A/C belt with a flashlight, while it's running. I was getting a stupid annoying squeak, and I thought it was the alternator on it's way out. If it's vibrating a lot, swap it out.
I thought the serpentine belt ran the whole car, but there is a smaller belt that drives the A/C unit, on the left side of the engine bay. (near the battery) Damn thing was vibrating like anything, and after looking at the belt, it was missing almost all of the ribs of the belt!
Got a new belt, all was quiet again.
Hope this helps!
D
1998 Z-28
Paul O'Brien-Hill wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.