HEATER!!!

My heater is messed up. When I turn it on it only gets cool and not even warm. I freeze my butt off in the mornings and would love some input on what I might need to change or how i could check anything.
thanks guys
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
It might help if you let us in on what car you got !
Rich

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

thermostat was removed,. Just a few generic things to check. JasperP
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Its a 94' Camaro. The fan works and it only puts out cool air. The water going into the heater is hot but no hot air is coming through the vents any input? Jasper wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Is the water hot FROM the heater ? ie. is there flow though the heater ?
Not sure about the 94, but some vent controls are vacuum actuated ? have you checked the vacuum lines ?
Also the heater control valve that lets hot water through the heater matrix (the one atached to the heater control knob inside the car)
Just a few things to look out for
Rich

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.