How do I mount Louvers on 82 Camaro (3rd Gen)?

I bought some louvers on Ebay. They have four clips on the side, that I assume clip to the sides of the hatchback. They also have two hinged connectors on top and two pad like connectors on the
bottom. The pads are very badly worn, look like they have been glued-on before. There is also some kind of bar at the bottom that doesn't look like it does anything.
Questions: 1. What were the pads originally like? I can't leave them bare metal with tar/glue on them. What should I do to them to make them like new? 2. What the heck is the little rod for at the bottom. I can't tell that it does any thing when I unclip it. Am I missing something? 3. Anything else I need to know/have to put these louvers on?
I'm going to clean them up (they were filthy and not packaged well) and then play with it a while. Any help would be appreciated ! Thanks!
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

the
before.
does
Hinged top connectors had foam tape on them, they simply glued to the window.

The bottom used in most cases, Velcro for holding them down. Taped to the glass, and to the louvre.

does
Thats for propping it up when you clean the glass.....:) Seriously.

They look stuuuuuuuuuuuuuuuuupid?

then
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.