Just bought a 1985 camaro with a 1989 motor fuel problems

I just purchased a 1985 camaro but the kid but a 1989 motor into it. It runs good exept he by passed the fuel sensor with a wire to the altenator to start the car. But everytime i start or turn off the car i
have to open the hood to take the wire of the back of the altenator. But i was driving down the road and the wire touched a hot part and melted the wire and the engine just stopped. How do i fix this? im not totally sure it is the fuel sensor anyone ver have this problem?????
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Sounds to me like he by-passed the fuel pump relay. Either buy the service manual the matches the wiring your car 1985 or 1989, or check out www.alldata.com which I think will cost you about $25.00
Check ebay for a service manual.

Randy
Remove 333 from email address to reply.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Kinda did the same with my '89 Firebird. Only I bypassed the computer and went from the relay to ground. Just hook up a toggle switch between your power source and fuel-pump... works like a charm, and only costs a couple bucks for the switch and wire. Mount it somewhere on your dash, and don't forget to shut it off..... not that I've never done that before.....
-Merius '89 Firebird Red 2.8L V6 5-Speed STD
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.