Turn signal ghost

Picked up my '68 Camaro yesterday, after 3 months in the body shop; the interior was & the engine compartment still is coated with dust. Driving down the road, the left turn signal will flicker, more on
concrete then on asphalt. The left fender was re-aligned. Would a short in the wiring cause the turn signal to flicker on? Or could there be dust in the switch, or bulb socket?
Seems to be the only problem, so far.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
puked:

What about the turn signal switch itself? -- lab~rat >:-) Do you want polite or do you want sincere?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
You didn't say if you only seen it flicker inside at the indicator. Did you have parking lights on ? if you did and the indicator was flashing on and off it could be a bad ground and back feed into the turn signal.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I didn't see it happen with the headlights off at lunch. Must be a bad ground, probably at the back where it was disassembled.
Thanks.
hipcheck wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Bruce Porter wrote:

    It's probably one of the front body harness grounds. Spend a hour or so inspecting the harness. It could be some miss-happ like the harness caught or a fastener thru the harness.
Charles
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.