wiring

does anyone have a wiring diagram for a 1995 camaro? If you do can i get it please. i just bought a 95 camaro and something is wrong with the wiring. if anyone has any idea what might be wrong please put your
info. in. thanks
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

In order to start to tell you some WAGs, you need to post what in hells wrong, not just some generic blanket statement.
Ok..here is an idea as to whats wrong...its broke.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
If you don't have any luck, try www.helminc.com You will have to pay maybe $130 but it's a small price to pay compared to paying a mechanic or doing it yourself but guessing at everything.
wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
95' Camaro wrote:

Without any information, I could't speculate what the problem is.
Electical problems usually come in the form of bad connections, shorts or opens, and a wiring diagram probably isn't going to be much help in those situations because the wires are going to the correct terminals (unless someone has hacked up your wiring and tried to redo it themselvs, then you may want to refer to a wiring diagram to double check their work).
I may be stating the obvious, but did you check the effected system for damaged wires or bad (or rusty) connections. are you having ignition or accessory problems?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
ignition wont start. new battery its the wiring somewhere
al wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
95' Camaro wrote:

Maybe. What are the symptoms when you try to start it? Does the security light come on? This could be the anti-theft system kicking in if the key is not being read right, or it could be the anti-theft starter interlock relay.
--
Cy Welch
89 Camaro RS 5.0 TBI
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I might be able to help. I have a 95 Firebird and was having the same problems shortly after I bought it. Even though we had the alternator tested, it tested fine. It was BAD. At one point the speedometer was bouncing with the turn signal speed. This I was told is a specific diod (sp?) in the alternator that would cause this. So we put in a new one but first a friend had a great idea - find a place that can test the original while IN the car. Guess what!? It failed!
Myabe you could write more about what you are experiencing.
I do have the shop manuals for the 95 FB and Camaro. (same books) 95' Camaro wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.