03 Ford F150

I've started having trouble. Started with Misfires. I changed all plugs, changed the fuel filter, air filter, and cleaned the MAF. Cleared the Codes and and it came up again. I checked my injectors for
leakage and none. My O2 sensors were reading too rich and too lean. That finally cleared. I went to relieve the fuel pressure and I had none. I was going to check the fuel pressure regulator. It's still not running right. Feels like it's missfiring and doesnt' have a lot of power. I've added fuel injector cleaner and sprayed it into the intake. Any thoughts??
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Are you sure you don't have a bad coil pack or some other ignition problem?
Ed
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
C. E. White wrote:

I checked all the Coils and there are great. Could it be one of my Catylic converters?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

problem?
How did you check the coils? The Ford procedure for checking them is incredibly involved. In fact it is so involved that it is cheaper to replace one than to "check" it. Did you try swapping coil packs between cylinders? What code are you getting? It is almost certainly not a catalytic converter.
Ed
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.