04 expidition cruise control not working

cruise control not working when sreering wheel buttons are deppressed no indication on dash was told could be a relay dont no were to start
-- Message posted using http://www.talkaboutautos.com/group/alt.autos.ford /
More information at http://www.talkaboutautos.com/faq.html
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Your 04 Expedition is not equipped with the electronic throttle control as featured on the F series. It does ahve the older cruise control servo type system. While your MY isn't covered under safety recall 05S28, the recall has been expanded several times to include more model years....
I would start by inspecting F2.5..... this is fuse #5 in the underdash fuse panel and should be a 7.5 amp fuse. If this fuse is blown, do not replace it until the reason has been discovered... especially, do NOT overfuse the circuit. Whehther the fuse is blown or not, proceed to the brake master cylinder.
At the front of the master cylinder, you will find the cruise control de-activation switch. Disconnect the wiring and inspect the switch for leakage and the wiring for any signs of overheating.... make any necessary repairs.....
FWIW, I have performed this recall on many, many vehicles and haven't seen any leaking switches THUS FAR.....
Remember.... your car is not currently covered under this FSA so your dealer will be unable or unauthorized to perfrom the necessary actions at this time and expect Ford to pay for it.... I do expect that there is a very good chance that FSA coverage may be expanded to cover your unit in the future. If you opt to purchase the recall harness and install it, the harness isn't expensive and, if you save the receipt and the FSA is expanded to cover your car, you should be able to be re-imbursed for the cost of the harness....
Disclaimer.... I am in no way associated with "talkaboutautos.com" and offer this as advice only. I do not feel that the site owners deserve to make money off my knowledge...

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.