1.9L rattling from engine question... than quickly just turns into me complaining

I have a 1991 Mercury Tracer.
it has a strange rattle coming from what I thought was the belt tensioner, it sounds worst at idle, they gradually gets drowned out in higher rpm's
(but never disappears fully)
I changed the tensioner today, and put on a new belt... now it sounds more scary and metallic. I know the most likely culprit is the timing area, but doing anything to this car is ridiculous, has anyone here successfully changed a timing belt on a car like this? the engine is in the bay horizontally and I could barely get the new belt on.
anyone else experience something like this?
I am just looking at the most likely culprits so I can take it to my mechanic without him telling me that everything under the sun is wrong with this thing...
Peter
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Check the exhaust heat shields:the welds tent to crack and cause a metallic rattle. Peter McDonald wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

I used a 7" diameter one around my catalytic converter.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
It is your catalytic convertor heat shield. A large hose clamp around it should solve the problem. Otherwise you can weld a new cat on, but the hose clamp is easier.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.