1986 Ford Aerostar idle problems

I have a 1986 Ford Aerostar and this problem has just started recently. its a 5 speed manual transmission, rear wheel drive with a 4 cylinder engine
and fuel injection.
When it first starts up, it doesn't want to idle. i have to give it gas to get it started and keep giving it a little gas to keep it from stalling out. So when i come to a stop, i have to put it in neutral, keep giving it gas and break with my left foot.
This problem only continues until the engine warms up, in which case it idles O.K. without stalling. I know hardly anything about cars, so any help would be appreciated.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
kitsunex wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
i am a ford tech and from what you are saying it sounds like a sticking IAC ( idle air control solenoid)mounted on the intake plenum
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
snipped-for-privacy@twcny.rr.com wrote:

step one ignore the iac for a bit and clean the throttle body... does it work now?
then you can try cleaning the iac they can be partially taken apart ..... clean all the black buildup off the pieces and try it
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.