1987 Mercury Marguis Won't Start

The car has run fine no miss nothing, shut the car off the other day and it hasn't started since. Checked for spark, ok, checked fuel pressure, ok, timing ok, the only trouble code I got was for a air charge temp sensor
which I replaced. Car turns over fine. Anyone have any ideas? Any help is greatly appreciated.
--
Regards,
Bear

Beauty is in the eye of the beer holder
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Could be not getting high enough spark(weak coil)even a tiny crack in dist.cap

it
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I've replaced the distributor cap and rotor. I get a good blue spark but I have a good coil I can try. I've also checked the compression and all cylinders are around 110 to 125. This problem really has me baffled. Thanks for the help
--
Regards,
Bear

Beauty is in the eye of the beer holder
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

back to basics, Spark, compression, fuel. all it needs. which one is it? KB
--
ThunderSnake #9 Warn once, shoot twice
460 in the pkup, 460 on the stand for another pkup
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

What about the crank sensor?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
No crank sensor but I've found out why it won't start. I checked the fuel pressure and its right where it should be so I assumed I was getting fuel into the cylinders but I pulled one of the injectors to see if it was shooting any fuel and it wasn't so I pulled another same thing. Is there a fuse or fusible link in the injector circuit or would this be a computer problem? Is there something other than the computer that controls the injectors? I'm scrounging the junk yards to find a computer.
--
Outgoing mail is certified Virus Free.
Checked by AVG anti-virus system (http://www.grisoft.com ).
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

It's most likley not the computer. Most likley where the injector harness connects into the main harness has come loose.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.