1991 Grand Marquis lack of power

I have a 1991 Grand Marquis which until recently needed a tune up - it was running roughly and lacked power.
I put in new spark plugs, new distributor cap and rotor, new spark plug
wires, new PCV valve and screen. In addition I did an oil and oil filter change as well as changed the air filter and fuel filter. The timing was set to specifications.
It runs much better now but there is still a problem. Acceleration is fine up to about 30 MPH and past about 65 MPH. Between 30 and 65 MPH it lacks power. If I hit the gas hard it drops into a lower gear. If I try to accelerate slowly it stumbles and seems to "hold back" - like it is not getting enough gas. It also detonates under these circumstances.
Can anyone tell me what to do next.
Any help would be appreciated.
Thanks
Bob
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Does it cut out and knock/ ping at certain speeds? My 86 Crown Vic 5.0 did that. I had a shop clean the injectors, that did the trick. The stuff one adds to the gas tank will not cut it. The way my mechanic explained it, when the injectors are clogged the fuel is not "misting" resulting in knocks/ pings.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.